IonCube Loader is a software tool, which is necessary to run files which are protected with ionCube PHP Encoder. The aforementioned is an application which is used to make PHP code human unreadable, as a way to protect it from reverse engineering and / or not authorized usage. Lots of script-driven apps, particularly online forums, content management systems and electronic commerce solutions are encrypted with ionCube PHP Encoder, therefore when you get a script and you find that ionCube is among the web hosting environment requirements, you have to make sure that your web hosting server has the instrument pre-installed. Though it's not that difficult to install it if you have your own server, it's close to impossible to do that on a shared hosting server as the PHP environment should be precompiled and all clients on the server will be affected.
IonCube in Cloud Hosting
When you get a Linux cloud hosting through us, it will be set up on our in-house made cloud platform where ionCube Loader is already set up, so you will not have any kind of problems to manage any script application that needs the instrument to function appropriately. Furthermore, we offer several different versions of PHP, therefore if you change the version, you'll have to activate ionCube again. Our system remembers the adjustments you make, so in case you go back to the previous release of PHP which was active for your account, ionCube Loader will already be enabled. Both the PHP version and the ionCube tool can be operated through the PHP Configuration section of our Hepsia website hosting Control Panel. Any change that you do takes literally just a mouse-click and it'll take effect immediately.
IonCube in Semi-dedicated Servers
As all semi-dedicated server accounts are set up on our advanced cluster platform and ionCube Loader is available on it, you'll be able to use any script app that needs the software tool so as to work properly. With just a few clicks in the Hepsia hosting Control Panel you are able to activate or deactivate ionCube for the PHP version that's currently active for your account. As we support several versions of PHP concurrently, you will need to do this any time you move to a new release, and when you revert back to a release which you've already used, our system will remember your preference and ionCube Loader will already be activated. In case you have a couple of sites inside the same account and they need different versions of PHP, you can create a php.ini file in every single domain folder and with a couple of lines of program code you can define both the PHP version as well as the status of ionCube no matter what is selected for the website hosting account as a whole.